あぶついったーのデータ取得を Twitter API 1.1 に対応させたときのメモ

投稿者: | 2013年5月26日
  • このエントリーをはてなブックマークに追加
  • このエントリーをはてなブックマークに追加

あぶついったーのバージョン 0.6 から正式に Twitter API 1.1 に対応したのですが、その際に使った Net::Twitter::Lite  に関するメモ。

結論から言うと、2013年5月26日現在、use Net::Twitter::Lite; とモジュール指定すると API1.0 が使われるので、use Net::Twitter::Lite::WithAPIv1_1; と指定しないと API 1.1 の仕様にならない

実際のコードはこんな感じ。

ちなみに最初 Net::Twitter::Lite::WithAPIv1_1->new() とするべきところを Net::Twitter::Lite->new() と書いちゃってて認証が通らなくて焦った。意外と陥りがちなポイントな上に、ググると同じ間違いを披露しているブロガーの方が結構いらしたので、注意点として一応書いておきます。

コメントを残す